Recherche sur le blog

mercredi 1 juin 2016

[WD21] Erreur vTable invalide à l'adresse X

Depuis hier l'Update 3 des éditeurs Windev, Webdev et Windev Mobile est disponible. Il s'agit de la version ayant passé avec succès le premier niveau de validation donc celle-ci n'est pas définitive. Installée sur deux PC différents, impossible de développer sans obtenir une erreur de ce genre :
vTable invalide à l'adresse 0x1f8e00e5
Pile:
0x1f8e00e5
0x7c406e56
0x98a28ab0
0x440f3678
0x601f527a
Cette erreur - qui apparait au bout d'une minute ou deux - est généralement liée au dongle / aux drivers de celui-ci (Sentinel HASP). Seulement voilà, les pilotes installés sont bien les derniers (7.41), et le problème se produit aussi bien sur Windows 8.1 que sur la 10.

Et bien sûr... Impossible d'aller plus loin. La seule issue possible est de cliquer sur le bouton Fermer. L'erreur a été signalée au support technique plus tôt dans l'après-midi, ainsi que sur les forums.

Si comme moi vous avez pris l'habitude de décocher la sauvegarde lors de l'installation des mises à jour de produits PC SOFT, alors vous risquez d'être à l'arrêt en attendant un correctif. Espérons que ça ne soit pas trop long...



Edit du 1/6/2016 - Pour information le bug se produit sur Windows 8.1 et 10 mais surtout, sur 3 machines au total, ayant des périphériques USB complètement différents. Tous étaient en Update 2 et Windev fonctionnait sans problème jusqu'à cette mise à jour.

Edit du 2/6/2016 - J'ai effectué quelques tests en ne laissant branché qu'un dongle et le phénomène est le même. J'ai dû lancer un outil de diagnostic et transférer un fichier au support, malheureusement en cette fin d'après-midi je n'ai aucune réponse concrète. J'ai en attendant désinstallé les pilotes et les 2 dongles, puis réinstallé proprement le dernier driver Sentinel HASP, sans succès.

Edit du 3/6/2016 - 3 jours déjà mais on tient le coup. Après l'exécution de l'outil de diagnostic, le support a relevé un conflit, sans en dire beaucoup plus. Si celui-ci est confirmé après l'envoi du deuxième fichier, l'article sera mis à jour en conséquence.

Le conflit est en fait dû à un pilote HP pour les claviers (à priori HP Hotkey Support). PC SOFT m'a envoyé un correctif, que vous pouvez télécharger en cliquant sur ce lien [miroir] (pack_fr_98553.zip).

Ensuite, décompressez les exécutables de Webdev 21 dans :

- Webdev21.exe, \Webdev 21\Programmes
- Webdev64local.exe, \Webdev 21\Programmes
- Webdev64net.exe, \Webdev 21\Programmes 
- Données\Webdev.wdl, \Webdev 21\Programmes\Données

Idem pour Windev:

- Windev21.exe, \Windev 21\Programmes
- Windev64local.exe, \Windev 21\Programmes
- Windev64net.exe, \Windev 21\Programmes 
- Données\Windev.wdl, \Windev 21\Programmes\Données

Idem pour Windev Mobile :

- Wd21Mobile.exe, \Windev Mobile 21\Programmes
- Windevmobile64local.exe, \Windev Mobile 21\Programmes
- Windevmobile64net.exe, \Windev Mobile 21\Programmes 
- Données\Windev Mobile.wdl, \Windev Mobile 21\Programmes\Données

9 commentaires:

Alain Gaumet a dit…

J'ai le même problème que toi (je suis en w10 64bits), et je suis ton fil avec attention.
j'ai entrepris les mêmes démarches

Xavier Boullard a dit…

Bonjour j'ai le meme pb également avec une install 32bits.
J'ai un clavier logitec sans fil.
l'utilisation du nv lanceur ne change rien.

je vais voir avec windev ...

J'utilise la meme clé sur un portable, et là TVB ...

Jacky a dit…

Bonjour, j'ai le même problème mais sauf que j'utilise Windev20. Il n'y aurai pas un correctif pour le 20

Vincent a dit…

Si votre version de WD est totalement à jour, cela signifie que le problème est causé par un autre driver installé sur le PC, et si cela implique un pilote HP ou autre vous devez voir directement avec PC SOFT pour obtenir un correctif propre à votre version.

En général les anciennes versions ne sont plus maintenues, j'espère pour vous qu'ils prendront en compte votre souci.

Anonyme a dit…

Bonjour j'ai le même problème mais moi c'est la version 20

On se bouge a dit…

Bonjour,

idem avec l installation des versions 22 de windev et windev mobile.

Anonyme a dit…

bonjour à vous les nazes ! la seule solution est de refaire le système et de réinstaller les dongles ! bonne chance à vous et le problème ne reviendra plus !

Vincent a dit…

L'idée est de procéder aux installations de programmes un à un pour justement isoler ce qui crée le conflit.
Mais ça c'est surtout le boulot des dév de WD ;-)
Quant à moi je n'ai plus jamais eu le souci car je n'utilise plus les logiciels de PC SOFT.

Samia Behloul a dit…
Ce commentaire a été supprimé par l'auteur.